Campground Manager Classic Live Support Our Story Team Testimonials Blog

ASTRA Campground Manager has a new version available

Schedule an Appointment Now

ASTRA Campground Manager has a new version available

For help in getting upgraded, make an appointment for us to help by clicking here.

See release notes for changes: https://app.box.com/s/wbnrl9lwc6nsl2sdakxmrfji725gexlu


I M P O R T A N T

OpenEdge, a division of Global Payments
SYSTEMS UPGRADE REQUIRED FOR
SECURITY ENHANCEMENTS

Important Bulletin Information Regarding Upcoming Early TLS & Cipher Suite Deprecation

Dear OpenEdge Partner,

To follow up on our previous communication, we want to provide additional details regarding the mandatory deprecation of SSL v 3.0, TLS 1.0, and TLS 1.1. OpenEdge will be removing all cipher suites that are not compatible with TLS 1.2 and only allow the use of four TLS 1.2 ciphers as outlined in this Technical Bulletin It may be necessary for you to make updates to your software to accommodate these changes. Your compliant solution must be in market by February 28th, 2018.

What is Required

It is critical that you make it a priority to confirm compatibility of your software with TLS 1.2 by sending a test transaction to our alternate processing IP which has been updated to only accept TLS 1.2 protocols.

Please see the Technical Bulletin for more information on confirming compatibility.

After you have attempted test transactions, we request that you click here to complete a short survey notifying us of your results.

In addition, OpenEdge is ensuring merchants are using a Remote Client Manager (RCM) that is compatible with TLS 1.2 encryption protocols and related cipher suites.

There are two methods OpenEdge is using to update the merchant’s Remote Client Manager (RCM) software based on the version currently in use by the merchant:

Self-Installing Software Patch: Merchants who are using Windows RCM v1.14 and above where the OpenEdge Updater application is also present will be pushed an update automatically from the phone home server that will self install. There is no action required by the merchant.

Software Upgrade: Merchants on lower Windows RCM versions and Mac OS RCM versions will be able to self service to download and install their own upgrade using the links and materials OpenEdge is providing them or they can call OpenEdge and we’ll work with them to complete the upgrade. Will be provide an updated install file for merchants to use in the coming weeks.
All merchants must be updated. Merchants not on the correct version by these dates may lose the ability to process using RCM.

OpenEdge is also reminding merchants that in order to maintain PCI compliance required by the card brands and OpenEdge, they must run their payment processing environment on an operating system that is still supported and receiving updates from the vendor. These are the same versions that OpenEdge supports with our product solutions. For example, Windows® 7 and above are the only supported operating systems from Microsoft®. Also and just as important — the merchant must be installing these operating system updates to be PCI compliant and receive critical and necessary security updates including operating system support for TLS 1.2 and associated ciphers.

Should you have further questions regarding this announcement or the remediation program, please contact your Strategic Partner Manager for more details.

Thank you for your attention to this important matter,

The OpenEdge Team

We are affordable for all campgrounds Quick Quote

Reach out to us with any questions or comments you may have

  • This field is for validation purposes and should be left unchanged.

Subscribe to our newsletter

Subscribe to our free email newsletter for valuable resources, tips, and news from Astra by Campground Manager.